PHP is amongst the most widely used class-based programming languages. It’s pretty popular because it’s free software, which can be used to build responsive sites like community web portals, web stores or school websites as opposed to static HTML websites. A PHP module should be present on the web server where a PHP-powered website is hosted so that its code can be read. Because there are no license charges for such a module and the language offers countless options for the applications that you set up, there are hundreds of millions of PHP-driven websites. On top of that, there’re an immense number of open-source PHP-based scripts, which you can use for your sites without needing to possess any coding capabilities. Considering the fact that there are a number of PHP versions, you need to make sure that the same version that you used while setting up your website is available on the web server as well.

PHP 4 and PHP 5 Support in Shared Web Hosting

Our shared web hosting servers support different PHP versions, which implies that your sites will run properly no matter if your PHP-based scripts are outdated. We realize that an old website doesn’t invariably mean an insecure one as you may have carried out lots of source code modifications. That’s why we support PHP 4, 5.2, 5.3, 5.4 and 5.5 and you can decide which one will be enabled for your shared hosting account. You can change the version with one single click through your Hepsia Control Panel and the new settings will take effect immediately. If you would like to run both older and newer scripts, there’s even a possibility to use a different version of PHP for each of your domain names at the same time.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

Our semi-dedicated servers support multiple PHP versions, which implies that you’ll be able to use all the Internet applications that you have set up over the years. The Hepsia hosting Control Panel, which comes bundled with each and every semi-dedicated server account, will permit you to set the version that you need with one mouse click. You can choose between PHP 4, 5.2, 5.3, 5.4 and 5.5. In case you’d like to host multiple sites under one and the very same account and they have various requirements related to the web hosting platform, you will be able to set a different PHP version for each of them no matter which version is selected for the account as a whole. That’s accomplishable owing to our custom cloud platform, which permits us to run multiple PHP versions simultaneously. By comparison, the vast majority of web hosts normally support one, in exceptionally rare cases – two versions.